您的位置:首页 > 其它

PAT - 甲级 - 1126. Eulerian Path (25)

2017-03-28 23:27 369 查看
题目描述:

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous
Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are calledEulerian. If there are exactly two vertices of odd degree, all Eulerian
paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is calledsemi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)
Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends
of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in
the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:
2 4 4 4 4 4 2
Eulerian

Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:
3 3 4 3 3
Non-Eulerian


题目思路:

题目给出n个结点的m条边。

题目要求:

1.输出每个结点的度(degree).

2.如果所有结点的度都是偶数(存在一条从某结点出发,经过所有的点和边且不重复,再回到起点的路线),输出"Eulerian".

3.如果有2个结点的读是奇数,其他的度都是偶数则输出"Semi-Eulerian",

4.除了情况2,3则输出"Non-Eulerian"

注意:2,3情况的前提条件是所有结点是连通的。

这里degree用一维数组记录,判断连通性使用了并查集。

题目代码:

#include <cstdio>
#include <cstring>
using namespace std;
int p[505];

int find(int x){
return p[x] == x ? x : p[x] = find(p[x]);
}

int d[505];

int n, m, x, y;
int main(){
scanf("%d%d",&n, &m);
memset(d,0,sizeof(d));
// 并查集初始化
for(int i = 1; i <= n; i++) p[i] = i;

for(int i = 1; i <= m; i++){
scanf("%d%d",&x, &y);
d[x]++; d[y]++;

int fx = find(x);
int fy = find(y);
if(fx != fy) p[fx] = fy;
}

int oddNum = 0; // 奇数度结点数
int rootNum = 0; // 根节点个数

for(int i = 1; i <= n; i++){
if(i!=1) printf(" ");
printf("%d",d[i]);

if(d[i]&1) oddNum ++;

if(find(i) == i) rootNum ++;
}
puts("");

if(!oddNum && rootNum == 1){
puts("Eulerian");
}
else if(oddNum == 2 && rootNum == 1){
puts("Semi-Eulerian");
}else{
puts("Non-Eulerian");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: