您的位置:首页 > 其它

Catch That Cow(抓住那头牛)

2017-03-28 21:50 183 查看
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17


Sample Output
4


Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
#define Max 100000
int visited[Max];
struct Way{
int x;
int time;
Way(int x1,int time1)
{
x=x1;
time=time1;
}
};
int main()
{
ios::sync_with_stdio(false);
int N,K;
memset(visited,0,sizeof(visited));
queue <Way> cow;
cin>>N>>K;
cow.push(Way(N,0));
visited
=1;
while(!cow.empty())
{
Way s=cow.front();
if(s.x==K)
{
cout<<s.time<<endl;
break;
}
else
{
if(s.x-1>=0&&!visited[s.x-1])//左移一位
{
cow.push(Way(s.x-1,s.time+1));
visited[s.x-1]=1;
}
if(s.x+1<=Max&&!visited[s.x+1])//右移一位
{
cow.push(Way(s.x+1,s.time+1));
visited[s.x+1]=1;
}
if(s.x*2<=Max&&!visited[s.x*2])//直接到达2*x点
{
cow.push(Way(s.x*2,s.time+1));
visited[s.x*2];
}
}
cow.pop();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: