您的位置:首页 > 其它

HDU 3294 Girls' research【最长回文子串】

2017-03-27 23:25 330 查看
题目来戳呀

Problem Description

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:

First step: girls will write a long string (only contains lower case) on the paper. For example, “abcde”, but ‘a’ inside is not the real ‘a’, that means if we define the ‘b’ is the real ‘a’, then we can infer that ‘c’ is the real ‘b’, ‘d’ is the real ‘c’ ……, ‘a’ is the real ‘z’. According to this, string “abcde” changes to “bcdef”.

Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.

Input

Input contains multiple cases.

Each case contains two parts, a character and a string, they are separated by one space, the character representing the real ‘a’ is and the length of the string will not exceed 200000.All input must be lowercase.

If the length of string is len, it is marked from 0 to len-1.

Output

Please execute
4000
the operation following the two steps.

If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output “No solution!”.

If there are several answers available, please choose the string which first appears.

Sample Input

b babd

a abcd

Sample Output

0 2

aza

No solution!

题意:

如果有最长回文串(长度≥2),就输出最长的首位置和末位置;

并且,第一个字母是真正的a的位置,还要输出最长回文字符串的真正字符串。

如果没有,输出No solution!

想法:

比赛时有一道manacher求回文串的裸题啊QAQ翻小白找后缀数组什么的做,结果某猪队直接套manacher模板就过了←论模板的重要性。

然后研究了一下manacher,虽然比赛时还是会直接用模板o(╯□╰)o

先看这个了解manacher

再看这个就基本懂了

这个和楼上一起吧差不多

最后配着很全的图和代码看一遍吧

对了,这个题始末位置的表达和怎么换掉字母还是蛮值得一看的^O^

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
const int maxn = 1e6+5;
using namespace std;
char MA[maxn*2];//加了一些不存在的符号变成奇数的字符新串
int MP[maxn*2];
char s[maxn*2];
char temp[2];
void Manacher(char s[], int len)
{
int l = 0;
MA[l++] = '$';//放在首位防止越界
MA[l++] = '#';
for(int i = 0; i < len; ++i)
{
MA[l++] = s[i];
MA[l++] = '#';
}
MA[l] = 0;
int mx = 0, id = 0;//mx是浏览过的回文串最右的位置,id是取到最优时的i值(第i个字符)
for(int i = 0; i < l; ++i)
{
//两大种情况,mp[i]是以i为中心拓展的最长回文字符串的一半
MP[i] = mx > i ? min(MP[2*id-i], mx-i) : 1;//括号前半部分是此时的i关于之前i的对称点的回文半径,后半部分是新i可以达到的回文半径
while(MA[i+MP[i]] == MA[i-MP[i]]) MP[i]++;//
if(i+MP[i]>mx)//说明i的位置没访问过,就从两边重新更新啦
{
mx = i + MP[i];
id = i;
}
}
}
int main()
{
while(scanf("%s%s",temp,s)!=EOF)
{
int len = strlen(s);
int l,r;
Manacher(s, len);
int ans = 0;
for(int i = 0; i < 2*len+2; ++i)
{
if(MP[i]>ans)
{
ans=MP[i];
l=(i-MP[i])/2;//起
r=(i+MP[i])/2-2;//终
}
/*ans = max(ans, MP[i]-1);
l=(i-MP[i])/2;
r=(i+MP[i])/2-2;*/
}
if(ans==2)cout<<"No solution!"<<endl;
else
{
printf("%d %d\n",l,r);
//int k=temp[0]-'a';//所以输入字符放到数组里应该是为了这里算差值吧
for(int i=l; i<=r; i++)
//printf("%c",(s[i]-'a'-k+26)%26+'a');
printf("%c",(s[i]-temp[0]+26)%26+'a');//这个转换字符的蛮独特啊==
cout<<endl;
}
}
return 0;
}


ps:明白这个了,存这个做manacher的模板辣!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: