您的位置:首页 > 其它

poj 1260 Pearls(DP)

2017-03-27 22:40 288 查看
题目链接:http://poj.org/problem?id=1260

Pearls

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9187 Accepted: 4630
Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary
people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl
in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. 

Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain
quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. 

Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is
actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the 

prices remain the same. 

For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. 

The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program. 

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one. 

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai
needed in a class (1 <= ai <= 1000). 

The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers. 

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list. 

Sample Input
2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output
330
1344

Source

Northwestern Europe 2002
[Submit]   [Go Back]   [Status]  
[Discuss]


Home Page   

Go
Back  

To top

题意:给你每种珠宝需要买的个数和价格,你可以按顺序买,也可以跳着买,到最后买的数量要和顺序买一样,并且钱比较少

例如样例Input的第二个例子:

3

1 10

1 11

100 12

需要买第一类1个,第二类1个,第三类100个

按常规支付为 (1+10)*10 + (1+10)*11 + (100+10)*12 = 1551元(一共买了102个珍珠)

但是如果全部都按照第三类珍珠的价格支付,同样是买102个,而且其中总体质量还被提高了,但是价格却下降了:(102+10)*12 = 1344元

解析:经典DP题,dp[i] = min(dp[i], dp[j] + (sum[i] - sum[j] + 10) * p[i]); 表示前i个种类的珍珠所要花的最少钱

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#define N 1009
using namespace std;
const int INF = 0x3f3f3f3f;

int a
, p
, sum
;
int dp
;

int main()
{
int t, n;
scanf("%d", &t);
while(t--)
{
scanf("%d", &n);
sum[0] = 0;
for(int i = 1; i <= n; i++)
{
scanf("%d%d", &a[i], &p[i]);
sum[i] = sum[i - 1] + a[i];
}
dp[0] = 0;
for(int i = 1; i <= n; i++)
{
dp[i] = INF;
for(int j = 0; j < i; j++)
{
dp[i] = min(dp[i], dp[j] + (sum[i] - sum[j] + 10) * p[i]);
}

}
printf("%d\n", dp
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: