您的位置:首页 > 其它

HDU3032 Nim or not Nim? 博弈

2017-03-27 19:34 281 查看
Nim or not Nim?

单击666传送

Problem Description

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.

Input

Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], …., s[N-1], representing heaps with s[0], s[1], …, s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)

Output

For each test case, output a line which contains either “Alice” or “Bob”, which is the winner of this game. Alice will play first. You may asume they never make mistakes.

Sample Input

2

3

2 2 3

2

3 3

Sample Output

Alice

Bob

最后一句我们假设他们很聪明一看就是博弈论的问题,但是这道题数据量太大了,通过样例大致可以看出他在描述计算SG的值去完成一些balabala的比较,好难的。还是找找规律好了。

自己没有找到唉,靠的百度,但是自己还是错了好几次,总是打错

但是这个异或的意思还是要懂的,就是将博弈的每一个堆当成子游戏的意思。

这道题本意就是分石子

#include <stdio.h>
int la(int n){
if(n%4==0)
return n-1;
if(n%4==3)
return n+1;
return n;
}
int main()
{int t;
scanf("%d",&t);
while(t--){
int n,f=0;
scanf("%d",&n);
while(n--){
int a;
scanf("%d",&a);
f^=la(a);
}
if(f)
printf("Alice\n");
else
printf("Bob\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: