您的位置:首页 > 产品设计 > UI/UE

[UVA] 540 Team Queue

2017-03-27 15:48 387 查看
题目:

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

Input

The input file will contain one or more test cases. Each test case begins with the number of teams t (1 ≤ t ≤ 1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0..999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands: • ENQUEUE x — enter element x into the team queue

• DEQUEUE — process the first element and remove it from the queue • STOP — end of test case

The input will be terminated by a value of 0 for t.

Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the imple- mentation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output

For each test case, first print a line saying ‘Scenario #k’, where k is the number of the test case. Then, for each ‘DEQUEUE’ command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input

2

3 101 102 103

3 201 202 203

ENQUEUE 101

ENQUEUE 201

ENQUEUE 102

ENQUEUE 202

ENQUEUE 103

ENQUEUE 203

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

2

5 259001 259002 259003 259004 259005

6 260001 260002 260003 260004 260005 260006

ENQUEUE 259001

ENQUEUE 260001

ENQUEUE 259002

ENQUEUE 259003

ENQUEUE 259004

ENQUEUE 259005

DEQUEUE

DEQUEUE

ENQUEUE 260002

ENQUEUE 260003

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

0

Sample Output

Scenario #1

101

102

103

201 202 203

Scenario #2

259001

259002

259003

259004

259005

260001

题意:就是给n个团队,再给出每个团队的成员。然后开始排长队。

每次入长队的时候,如果长队中有自己团队的成员,那么可以排到最后一个团队成员的后面。输出每次出队的成员。

分析:queue乱搞一发。

代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<map>
using namespace std ;

const int MAX_N = 1000+5 ;

int main(){
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int n ;
int count = 0 ;
while(cin>>n&&n){
printf("Scenario #%d\n",++count);
map<int,int> team ;
queue<int> q ,q2[MAX_N];
for(int i = 0 ;i < n ; i++){
int k,x ;cin>>k ;
for(int j = 0 ; j < k ; j++){
scanf("%d",&x),team[x]=i;
}
}

char comm[20];
for(;;){
cin>>comm;
//printf("hahah\n");
if(comm[0]=='S') break ;
else if(comm[0]=='E'){
int x ; scanf("%d",&x);
int t = team[x];
if(q2[t].empty()) q.push(t);
q2[t].push(x);
}
else if(comm[0]=='D'){
int t = q.front();
int ans=q2[t].front();
q2[t].pop();
if(q2[t].empty()) q.pop();
printf("%d\n",ans);
}
}
cout<<endl;
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: