您的位置:首页 > 理论基础 > 数据结构算法

POJ 2777 Count Color

2017-03-27 15:06 316 查看
Count Color

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 45101Accepted: 13664
Description
Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment
with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 

2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the
beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input
First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains
"C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.
Output
Ouput results of the output operation in order, each line contains a number.
Sample Input
2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output
2
1

Source
POJ Monthly--2006.03.26,dodo

线段树必刷题~~~
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int N = 100010;
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
int sum;
struct Tree{
int l,r,col;
bool cover;//用于标记区间内的颜色是否相同(效率)
}tre[N<<4];
int n,t,m;
void Built(int l,int r,int now){
tre[now].l=l;tre[now].r=r;
tre[now].col=1;tre[now].cover=true;
if(tre[now].l==tre[now].r) return ;
int mid=(l+r)>>1;
Built(l,mid,now<<1);
Built(mid+1,r,now<<1|1);
}
void PushDown(int now){
tre[now<<1].col=tre[now].col;
tre[now<<1].cover=1;
tre[now<<1|1].col=tre[now].col;
tre[now<<1|1].cover=1;
tre[now].cover=0;
}
void UpDate(int val,int l,int r,int now){
if(l<=tre[now].l&&tre[now].r<=r){
tre[now].col=val; tre[now].cover=1;
return;
}
if(tre[now].col==val) return ;
if(tre[now].cover) PushDown(now);
int mid=(tre[now].l+tre[now].r)>>1;
if(r<=mid) UpDate(val,l,r,now<<1);
else if(l>=mid+1) UpDate(val,l,r,now<<1|1);
else{
UpDate(val,l,mid,now<<1);
UpDate(val,mid+1,r,now<<1|1);
}
tre[now].col=tre[now<<1].col | tre[now<<1|1].col;
}
void Query(int l,int r,int now){
if(l<=tre[now].l&&tre[now].r<=r){
sum |= tre[now].col;
return ;
}
if(tre[now].cover){
sum |= tre[now].col;//颜色种类相加的运算代码
return ;// 提高效率
}
int mid=(tre[now].l+tre[now].r)>>1;
if(r<=mid) Query(l,r,now<<1);
else if(l>=mid+1) Query(l,r,now<<1|1);
else{
Query(l,mid,now<<1);Query(mid+1,r,now<<1|1);
}
}
int Solve(){
int ans=0;
while(sum){
if(sum & 1) ans++;
sum>>=1;
}
return ans;
}
int main(){
while(~scanf("%d%d%d",&n,&t,&m)){
Built(1,n,1);
char op[5]; int a,b,c;
while(m--){
scanf("%s",op);
if(op[0]=='C'){
scanf("%d%d%d",&a,&b,&c);
if(a>b) swap(a,b);
UpDate(1<<(c-1),a,b,1);
}
else {
scanf("%d%d",&a,&b);
if(a>b) swap(a,b);
sum=0;
Query(a,b,1);
printf("%d\n",Solve());
}
}
}
return 0;
}

本体的关键在于能否想到使用'|'运算
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  线段树 数据结构