您的位置:首页 > 其它

Poj 2411 Mondriaan's Dream(状压DP)

2017-03-27 09:08 357 查看
Mondriaan’s Dream

Time Limit: 3000MS Memory Limit: 65536K

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.



Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.



Sample Input

1 2

1 3

1 4

2 2

2 3

2 4

2 11

4 11

0 0

Sample Output

1

0

1

2

3

5

144

51205

Source

Ulm Local 2000

题意:用1*2的砖块来覆盖地面的方案数.

/*
状压DP.
f[i][S]表示当前第i行,状态为S.
我们发现每一行状态只和前一行相关.
然后就可以DP辣.
枚举所有可行状态转移.
0 不放/竖着的上面那块
1 横着/竖着的下面那块
强行把竖着的状态给下边那个.
因为必须要填满,
所以状态合不合法就比较好转移了.
*/
#include<iostream>
#include<cstring>
#include<cstdio>
#define MAXN 5001
#define LL long long
using namespace std;
LL f[21][MAXN];
int n,m;
bool pre(int s)
{
for(int i=0;i<m;)
{
if(s&(1<<i))
{
if(i==m-1) return false;
if(s&(1<<i+1)) i+=2;
else return false;
}
else i++;
}
return true;
}
bool check(int s,int ss)
{
for(int i=0;i<m;)
{
if(s&(1<<i))
{
if(ss&(1<<i))
{
if(i==m-1||!(s&(1<<i+1))||!(ss&(1<<i+1))) return false;
else i+=2;
}
else i++;
}
else {
if(!(ss&(1<<i))) return false;
else i++;
}
}
return true;
}
void slove()
{
memset(f,0,sizeof f);
for(int s=0;s<=(1<<m)-1;s++) if(pre(s)) f[1][s]=1;
for(int i=2;i<=n;i++)
for(int s=0;s<=(1<<m)-1;s++)
for(int ss=0;ss<=(1<<m)-1;ss++)
if(check(s,ss)) f[i][s]+=f[i-1][ss];
printf("%lld\n",f
[(1<<m)-1]);
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
if(!n&&!m) break;
if(n<m) swap(n,m);
slove();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: