您的位置:首页 > 其它

B1042. 字符统计(20)

2017-03-26 14:11 344 查看
请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST. There ARE numbers and other symbols 1&2&3………..

输出样例:

e 7

#include<cstdio>
#include<iostream>
#include<string>
#include<cctype>
using namespace std;

int main()
{
string str;
int a[150] = { 0 };
int max_c = 0;

getline(cin, str);
for (int i = 0; i < str.size(); ++i)
{
if (isalpha (str[i]))
{
str[i] = tolower(str[i]);
++a[str[i]];
if (a[str[i]] > a[max_c])
max_c = str[i];
else if (a[str[i]] == a[max_c])
{
max_c = max_c < str[i] ? max_c : str[i];
}
}

}
printf("%c %d", max_c, a[max_c]);

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: