您的位置:首页 > 编程语言 > Java开发

hdu Prime Ring Problem (java 简单DFS)

2017-03-26 11:08 323 查看

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 48135    Accepted Submission(s): 21253

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

Input

n (0 < n < 20).

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input

6

8

 

Sample Output

Case 1:

1 4 3 2 5 6

1 6 5 2 3 4

Case 2:

1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

 

Source

Asia 1996, Shanghai (Mainland China)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016

题目大意:给定数字n,由从1-n 这n个数字围成的环,要求相邻两个数字的和是素数。求出所有满足要求的排列情况。输出格式:每组数字以1开头,各组数字按字典序排列。(注意首尾数字的判断)

代码如下:

import java.util.*;

public class Main {
public static int n;
public static boolean[] prime = new boolean[50]; //标记数字是否是素数
public static boolean[] vis = new boolean[25]; //标记数字是否填过
public static int[] ans = new int[25]; //纪录路径
public static boolean p ;
public static void get_prime(){ //写素数筛
Arrays.fill(prime, false);
prime[2]=true;
for(int i=2;i<50;i++){
boolean flog = true;
for(int j=2;j*j<=i;j++){
if(i%j==0){
flog = false;
break;
}
}
if(flog){
prime[i] = true;
}
}
}

public static void main(String[] args){
int cnt=0;
Scanner sc = new Scanner(System.in);
get_prime();
while(sc.hasNext()){
cnt++;
n = sc.nextInt();
Arrays.fill(vis, false);
Arrays.fill(ans, 0);
ans[1] = 1;
p = false;
System.out.println("Case "+cnt+":");
DFS(2);
System.out.println();
}
}

public static void DFS(int dig){
if(dig>n){
if(prime[ans[dig-1]+1]){
for(int i=1;i<=n;i++){
if(i<n){
System.out.print(ans[i]+" ");
}else{
System.out.println(ans[i]);
}
}
}
return ;
}
for(int i=2;i<=n;i++){
if(!vis[i] && prime[i+ans[dig-1]]){
vis[i] = true;
ans[dig] = i;
DFS(dig+1);
vis[i] = false;
}
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: