您的位置:首页 > 其它

Not so Mobile UVA - 839

2017-03-25 20:22 429 查看
https://vjudge.net/problem/UVA-839

Before being an ubiquous communications gadget, a mobile

was just a structure made of strings and wires suspending

colourfull things. This kind of mobile is usually found hanging

over cradles of small babies.

The figure illustrates a simple mobile. It is just a wire,

suspended by a string, with an object on each side. It can

also be seen as a kind of lever with the fulcrum on the point where the string ties the wire. From the

lever principle we know that to balance a simple mobile the product of the weight of the objects by

their distance to the fulcrum must be equal. That is Wl × Dl = Wr × Dr where Dl

is the left distance,

Dr is the right distance, Wl

is the left weight and Wr is the right weight.

In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure.

In this case it is not so straightforward to check if the mobile is balanced so we need you to write a

program that, given a description of a mobile as input, checks whether the mobile is in equilibrium or

not.

Input

The input begins with a single positive integer on a line by itself indicating the number

of the cases following, each of them as described below. This line is followed by a blank

line, and there is also a blank line between two consecutive inputs.

The input is composed of several lines, each containing 4 integers separated by a single space.

The 4 integers represent the distances of each object to the fulcrum and their weights, in the format:

Wl Dl Wr Dr

If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define

the the sub-mobile. In this case we compute the weight of the sub-mobile as the sum of weights of

all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are zero then the

following lines define two sub-mobiles: first the left then the right one.

Output

For each test case, the output must follow the description below. The outputs of two

consecutive cases will be separated by a blank line.

Write ‘YES’ if the mobile is in equilibrium, write ‘NO’ otherwise.

Sample Input

1

0 2 0 4

0 3 0 1

1 1 1 1

2 4 4 2

1 6 3 2

Sample Output

YES

这个代码仿佛打开了一扇大门- -

原来递归还可以这样用 - -

这是姿势- -

刷算法书的好处

#include<bits/stdc++.h>
using namespace std;

bool solve(int &w)//引用w 所以w的值是动态的,一直累加左右的重量,- -好强的想法
{
int w1,d1,w2,d2;
bool b1=true,b2=true;

cin>>w1>>d1>>w2>>d2;

if(!w1) b1=solve(w1);
if(!w2) b2=solve(w2);

w=w1+w2;

return b1&&b2&&(w1*d1==w2*d2);
}

int main()
{
int t,w;
cin>>t;
while(t--)
{
if(solve(w)) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
if(t) cout<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: