您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2017-03-25 11:34 447 查看


1002. A+B for Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2

题意分析:Ni代表指数,aNi代表系数,由于n不大于1000,故可以定义double性的数组p,利用桶排序原理,要注意格式输出哟

AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<stdio.h>
#include<cstring>
#include<string.h>
using namespace std;
int main()
{
        int num1;
        double p[1005];
        while(scanf("%d",&num1)!=EOF)
        {
                memset(p,0,sizeof(p));
                int e;
                double c;
                while(num1--)
                {
                        scanf("%d%lf",&e,&c);
                        p[e]+=c;
                }
                int num2;
                scanf("%d",&num2);
                while(num2--)
                {
                        scanf("%d%lf",&e,&c);
                        p[e]+=c;
                }
                int cnt=0;
                for(int i=0;i<=1005;i++)
                        if(fabs(p[i])>1e-6)
                        cnt++;
                printf("%d",cnt);
                for(int i=1005;i>=0;i--)
                        if(fabs(p[i])>1e-6)
                        printf(" %d %.1lf",i,p[i]);
                printf("\n");
        }
        return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: