您的位置:首页 > 其它

【POJ 2255 Tree Recovery】+ 二叉树

2017-03-24 21:41 417 查看
Tree Recovery

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 14637 Accepted: 9088

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

D

/ \

/   \

B     E

/ \     \

/   \     \

A     C     G

/

/

F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input

The input will contain one or more test cases.

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output

For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG

BCAD CBAD

Sample Output

ACBFGED

CDAB

根据中序 和 前序 构造,LRD输出

AC代码:

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
const int K = 30;
char q[K],z[K],l[K],r[K];
char gz(int l1,int r1,int l2,int r2){
if(l1 > r1) return '.';
char s = q[l2];
int pl = l1;
while(z[pl] != s) pl++;
int nl = pl - l1;
l[s] = gz(l1,pl - 1,l2 + 1,l2 + nl);
r[s] = gz(pl + 1,r1,l2 + nl + 1,r2);
return s;
}
void sc(char a){
if(l[a] != '.') sc(l[a]);
if(r[a] != '.') sc(r[a]);
printf("%c",a);
}
int main()
{
while(scanf("%s %s",q + 1, z + 1) != EOF){
int n = strlen(q + 1);
gz(1,n,1,n);
sc(q[1]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: