您的位置:首页 > 其它

poj 2255 Tree Recovery (二叉树的顺序遍历)

2017-03-24 21:29 453 查看
Tree Recovery

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14636 Accepted: 9087
Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 

This is an example of one of her creations: 
D

/ \

/   \

B     E

/ \     \

/   \     \

A     C     G

/

/

F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF
and the inorder traversal is ABCDEFG. 

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 

However, doing the reconstruction by hand, soon turned out to be tedious. 

So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 

Input is terminated by end of file. 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD

Sample Output
ACBFGED
CDAB

二叉树是递归遍历,先序首先确定当前树的根节点,在通过中序遍历确定位于根节点两侧的两棵子树,就这样递归遍历

#include<cstdio>
#include<cstring>
char pre[30],in[30];
//p1,p2存放先序遍历的下标
//i1,i2存放中序遍历的下标
void recovery(int p1,int p2,int i1,int i2)
{
if(p1>p2)
return;
int i,len1;
for(i=i1;i<=i2;i++)
{
if(in[i]==pre[p1])
break;
}
len1=i-i1;
recovery(p1+1,p1+len1,i1,i-1);
recovery(p1+1+len1,p2,i+1,i2);
printf("%c",pre[p1]);
}
int main()
{
while(~scanf("%s%s",pre,in))
{
len=strlen(pre);
recovery(0,len-1,0,len-1);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: