您的位置:首页 > 其它

FZU1050 Number lengths(数论,规律,概念)

2017-03-24 13:47 267 查看
题目:


 Problem 1050 Number lengths

Accept: 1096    Submit: 2263

Time Limit: 1000 mSec    Memory Limit : 32768 KB



 Problem Description

N! (N factorial) can be quite irritating and difficult to compute for large values of N. So instead of calculating N!, I want to know how many digits are in it. (Remember that N! = N * (N - 1) * (N - 2) * ... * 2 * 1)



 Input

Each line of the input will have a single integer N on it 0 < N < 1000000 (1 million). Input is terminated by end of file.



 Output

For each value of N, print out how many digits are in N!.



 Sample Input

13 32000



 Sample Output

1 1 130271

Submit  Back  Status  Discuss
思路:

题目的意思是问你一个数的阶乘里面有几位数,以前做水题的时候做过,昨天比赛又遇到了,开一篇博客存一下记录阶乘位数的方法

求一个数阶乘的位数 

可以直接采用log10求一个数阶乘的位数 

N=n! 
方法1 
log10(n!) 
=log10(1∗2∗3…∗n) 
=log10(1)+log10(2)+…+log10(n)

log10N表示以10为底,N的对数。缩写是lgN.

natural logarithm 自然对数 

natural 英 [‘nætʃ(ə)r(ə)l] 美 [‘nætʃrəl] 

logarithm 英 [‘lɒgərɪð(ə)m; -rɪθ-] 美 [‘lɔɡərɪðəm]

代码:

#include <stdio.h>
#include <string.h>
#include <string>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define N 100+20
#define M 1000000+10
#define LL long long
using namespace std;
int a[M];
void biao()
{
double x=1;
for(int i=1; i<=M; i++)
{
x+=log10(double(i));
a[i]=floor(x);
}

}
int main()
{

int n;
biao();
while(~scanf("%d",&n))
printf("%d\n",a
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: