您的位置:首页 > 其它

FZU 1050 Number lengths (思维题)

2017-03-24 11:10 232 查看



Problem Description

N! (N factorial) can be quite irritating and difficult to compute for large values of N. So instead of calculating N!, I want to know how many digits are in it. (Remember that N! = N * (N - 1) * (N - 2) * ... * 2 * 1)



Input

Each line of the input will have a single integer N on it 0 < N < 1000000 (1 million). Input is terminated by end of file.



Output

For each value of N, print out how many digits are in N!.



Sample Input

1
3
32000



Sample Output

1
1
130271

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<cmath>
typedef long long ll;
using namespace std;
int t;
int main()
{
int n;
while(~scanf("%d",&n))
{
double sum=0;
for(int i=1; i<=n; i++)
{
sum+=(double)log10((double)i);
}
int b=(int)sum;
printf("%d\n",b+1);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: