您的位置:首页 > 其它

Number lengths FZU - 1050

2017-03-23 23:03 190 查看
N! (N factorial) can be quite irritating and difficult to compute for large values of N. So instead of calculating N!, I want to know how many digits are in it. (Remember that N! = N * (N - 1) * (N - 2) * … * 2 * 1)

Input

Each line of the input will have a single integer N on it 0 < N < 1000000 (1 million). Input is terminated by end of file.

Output

For each value of N, print out how many digits are in N!.

Sample Input

1

3

32000

Sample Output

1

1

130271

//N!位数应该是 log10(1)+log10(2)+···+log10(n) 取整加1,
//注意:log10(n)传入的值必须是double型,所以要进行强制转换!
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std;

const int INF=1e9+7;
const int maxn=110;
typedef long long ll;

int n;

int main()
{
while(~scanf("%d",&n))
{
int i,j=0;
double sum=0;
for(i=1; i<=n; i++)
sum+=log10(double(i));
j=(int)sum+1;
printf("%d\n",j);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  公式