您的位置:首页 > 其它

二分——Poj 3273 Monthly Expense

2017-03-23 20:31 357 查看
题目:

Monthly Expense


Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input
Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input

7 5
100
400
300
100
500
101
400
Sample Output

500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.


AC 代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstdlib>
using namespace std;
int a[100010];
int L,N,M;
bool check (int x)
{
int s = a[0],j = 1, i;
for (i = 1; i < N; i++)
{
if ( (s + a[i]) > x)  {j++; s = a[i];}
else s += a[i];
}
if (j <= M)   return true;
else return false;
}
int main()
{
int i,max1=0;
cin >> N >> M;
memset (a, 0, sizeof(a));
for (i = 0; i < N; i++)
{
cin >> a[i];
max1 = max1 >a[i]? max1:a[i];
}
int st = max1-1, ed = 1e9+1;
while (ed - st > 1)
{
int mid = st + (ed - st) / 2;
if (check(mid))  ed = mid;
else            st = mid;
}
cout << ed <<endl;
return 0;
}


题解 :

二分查找
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  二分查找