您的位置:首页 > 其它

Silver Cow Party 【双向最短路】

2017-03-23 19:33 239 查看


Silver Cow Party



 

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤
100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the
party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X 

Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi,
requiring Ti time units to traverse.

Output
Line 1: One integer: the maximum of time any one cow must walk.

Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3


Sample Output
10


Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
思路:  本来一看是双向的距离 (对于floyd算法来说只要没有负环,就都可以算最短路,有向图or无向图) 就像用floyd但是一看数据,,铁定超时。。就只能用djk 扫两遍了
代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#define inf 0x3f3f3f
#define M 1000+10
#define mod 100
using namespace std;
int n,m,x;
int mp[M][M];
int v[M];
int dis1[M];
int dis2[M];
void getmp()
{
int i,j;
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
if(i==j) mp[i][j]=0;
else mp[i][j]=mp[j][i]=inf;
}

for(i=0;i<m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
if(mp[a][b]>c)
mp[a][b]=c;
}
}
void floyd()
{
int i,k,j;
for(k=1;k<=n;k++)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
if(mp[i][j]>mp[i][k]+mp[k][j])
mp[i][j]=mp[i][k]+mp[k][j];
}
}
}
void djk1()
{
int i,j,k;
int min,next;
for(i=1;i<=n;i++)
{
v[i]=0;
dis1[i]=mp[i][x]; // 这里注意方向
}
v[x]=1;
for(j=2;j<=n;j++)
{
min=inf;
for(i=1;i<=n;i++)
{
if(!v[i]&&dis1[i]<min)
{
min=dis1[i];
next=i;
}
}
if(min==inf) break;
v[next]=1;
for(i=1;i<=n;i++)
{
if(!v[i]&&dis1[i]>dis1[next]+mp[i][next])  //  这里要注意方向
dis1[i]=dis1[next]+mp[i][next];
}
}
}
void djk2()
{
int i,j,k;
int min,next;
for(i=1;i<=n;i++)
{
v[i]=0;
dis2[i]=mp[x][i];  //**
}
v[x]=1;
for(j=2;j<=n;j++)
{
min=inf;
for(i=1;i<=n;i++)
{
if(!v[i]&&dis2[i]<min)
{
min=dis2[i];
next=i;
}
}
if(min==inf) break;
v[next]=1;
for(i=1;i<=n;i++)
{
if(!v[i]&&dis2[i]>dis2[next]+mp[next][i]) // **
dis2[i]=dis2[next]+mp[next][i];
}
}
}
int main()
{
while(~scanf("%d%d%d",&n,&m,&x))
{
int i;
getmp();
djk1();
djk2();
int maxx=0;
for(i=1;i<=n;i++)
{
maxx=max(dis1[i]+dis2[i],maxx);
}
printf("%d\n",maxx);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: