您的位置:首页 > 其它

Supermarket poj 1456 (贪心,并查集)

2017-03-23 15:42 267 查看
Description
A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes
precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit
of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.

For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts
at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.



Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling
deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
5 20  50 10

Sample Output
80
185

Hint
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.
并查集和贪心的思路是一样的,但是所用的算法不同 。并查集:我们根据f[] 数组 和find()函数来求第d天的父节点 如果是自己本身则返回,否则就往前一天知道V<=0
找不到有一天可以将物品卖出,具体看代码:
并查集:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<ctype.h>
#include<math.h>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<string>
#include<iostream>
#include<algorithm>
#include<utility>
#include<iomanip>
#include<time.h>
typedef long long ll;
const double Pi = acos(-1.0);
const int N = 1e6+10, M = 1e3+20, mod = 1e9+7, inf = 2e9+10;
const double e=2.718281828459 ;
const double esp=1e-9;
using namespace std;
int n;
struct node
{
int p;
int d;
} a[10005];
int f[10005];
bool cmp(node a,node b)
{
return a.p>b.p;
}
int find(int x)
{
if(f[x]==x)return x;
else return f[x]=find(f[x]);
}
int main()
{
while(~scanf("%d",&n))
{
for(int i=0; i<10010; i++) f[i]=i;
for(int i=0; i<n; i++) scanf("%d%d",&a[i].p,&a[i].d);
sort(a,a+n,cmp);
int sum=0;
for(int i=0; i<n; i++)
{
int v=find(a[i].d);
if(v>0)
{
f[v]=v-1;
sum+=a[i].p;
}
}
printf("%d\n",sum);
}
return 0;
}

贪心:
#include<cstdio>
#include<cstring>
#include<stdlib.h>
#include<ctype.h>
#include<math.h>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<string>
#include<iostream>
#include<algorithm>
#include<utility>
#include<iomanip>
#include<time.h>
typedef long long ll;
const double Pi = acos(-1.0);
const int N = 1e6+10, M = 1e3+20, mod = 1e9+7, inf = 2e9+10;
const double e=2.718281828459 ;
const double esp=1e-9;
using namespace std;

struct node
{
int p;
int d;
} a[10100];
bool cmp(node a,node b)
{
if(a.p<b.p) return false;
return true;
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int vis[10100]={0};
for(int i=1; i<=n; i++)
{
scanf("%d%d",&a[i].p,&a[i].d);
}
sort(a+1,a+n+1,cmp);
int sum=0;
for(int i=1; i<=n; i++)
{
for(int j=a[i].d ; j>=1; j--)
{
if(!vis[j])
{
vis[j]=1;
sum+=a[i].p;
break;
}
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: