您的位置:首页 > 其它

团体程序设计天梯赛L2-002 链表去重

2017-03-22 18:12 225 查看


L2-002. 链表去重

时间限制

300 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

陈越

给定一个带整数键值的单链表L,本题要求你编写程序,删除那些键值的绝对值有重复的结点。即对任意键值K,只有键值或其绝对值等于K的第一个结点可以被保留。同时,所有被删除的结点必须被保存在另外一个链表中。例如:另L为21→-15→-15→-7→15,则你必须输出去重后的链表21→-15→-7、以及被删除的链表-15→15。

输入格式:

输入第一行包含链表第一个结点的地址、以及结点个数N(<= 105 的正整数)。结点地址是一个非负的5位整数,NULL指针用-1表示。

随后N行,每行按下列格式给出一个结点的信息:

Address Key Next

其中Address是结点的地址,Key是绝对值不超过104的整数,Next是下一个结点的地址。

输出格式:

首先输出去重后的链表,然后输出被删除结点组成的链表。每个结点占一行,按输入的格式输出。
输入样例:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

输出样例:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1


提交代码

——————————————————————————————————————

数组模拟链表,用下标表示地址,开一个数组记录是否出现过。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <string>
#include <set>
#include <map>
using namespace std;

#define myabs(a) a>=0?a:-a

struct node
{
int data;
int next;
} a[100010];
int cnt[100005];

int main()
{
int p,q,v,root,n;
while(~scanf("%d%d",&root,&n))
{
memset(cnt,0,sizeof cnt);
memset(a,-1,sizeof a);
for(int i=0; i<n; i++)
{
scanf("%d%d%d",&p,&v,&q);
a[p].data=v;
a[p].next=q;
}
int croot=-1,cpos;
int rt=root,pos=root;
while(rt!=-1)
{
if(cnt[myabs(a[rt].data)]==0)
{
cnt[myabs(a[rt].data)]++;
pos=rt;
}
else
{
if(croot==-1)
{
croot=rt;
cpos=rt;
}
else{
a[cpos].next=rt;
cpos=rt;

}

a[pos].next=a[rt].next;
}
rt=a[rt].next;
}
a[cpos].next=-1;
rt=root;
while(rt!=-1)
{
printf("%05d %d ",rt,a[rt].data);
if(a[rt].next==-1)
printf("%d\n",a[rt].next);
else
printf("%05d\n",a[rt].next);
rt=a[rt].next;

}
rt=croot;
while(rt!=-1)
{
printf("%05d %d ",rt,a[rt].data);
if(a[rt].next==-1)
printf("%d\n",a[rt].next);
else
printf("%05d\n",a[rt].next);
rt=a[rt].next;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: