您的位置:首页 > 其它

poj 2635 The Embarrassed Cryptographer (素数筛选优化+同余定理)

2017-03-21 10:33 351 查看
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes,
and are believed to be secure because there is no known method for factoring such a product effectively. 

What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users
keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size
of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input
143 10
143 20
667 20
667 30
2573 30
2573 40
0 0


Sample Output
GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31


打个一百万的素数表,利用一个数如果有因数一定会在log(n)里找到来优化,处理因子有2的数加快运算;

用千分制代替十分制减少数组长度

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;
const int N = 1040400;
int vis
, prime
, num
[3];
char str
;

int main()
{
memset(vis,0,sizeof(vis));
int k=0;
int t=(int)sqrt(N*1.0);
for(int i=2;i<=t;i++)
{
if(vis[i]) continue;
if(i%2==0) continue;
for(int j=2*i;j<N;j+=i) vis[j]=1;
}
for(int i=2;i<N;i++)
if(!vis[i]) prime[k++]=i;
int n;
while(scanf("%s %d",str,&n)!=EOF&&n)
{
if(str[0]=='0'&&n==0) break;
int len=strlen(str), cnt=0;
for(int i=0;str[i]!='\0';i++)
{
if(i+2<len)
{
num[cnt][1]=1000;
num[cnt++][0]=(str[i]-'0')*100+(str[i+1]-'0')*10+(str[i+2]-'0');
i+=2;
}
else if(i+1<len)
{
num[cnt][1]=100;
num[cnt++][0]=(str[i]-'0')*10+(str[i+1]-'0');
i+=1;
}
else if(i<len)
{
num[cnt][1]=10;
num[cnt++][0]=(str[i]-'0');
}
}
int flag=0;
for(int i=0;i<k;i++)
{
if(prime[i]>=n) break;
int sum=0;
for(int j=0;j<cnt;j++)
{
sum=sum*num[j][1]+num[j][0];
sum%=prime[i];
}
if(sum==0)
{
printf("BAD %d\n",prime[i]);
flag=1;
break;
}
}
if(!flag)puts("GOOD");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: