您的位置:首页 > 其它

hdu 6011 Lotus and Characters

2017-03-19 21:13 471 查看
Problem Description

Lotus has n kinds
of characters,each kind of characters has a value and a amount.She wants to construct a string using some of these characters.Define the value of a string is:its first character's value*1+its second character's value *2+...She wants to calculate the maximum
value of string she can construct.

Since it's valid to construct an empty string,the answer is always ≥0。

 

Input

First line is T(0≤T≤1000) denoting
the number of test cases.

For each test case,first line is an integer n(1≤n≤26),followed
by n lines
each containing 2 integers vali,cnti(|vali|,cnti≤100),denoting
the value and the amount of the ith character.

 

Output

For each test case.output one line containing a single integer,denoting the answer.

 

Sample Input

2
2
5 1
6 2
3
-5 3
2 1
1 1

 

Sample Output

35
5

 

Source

BestCoder Round #91

大的肯定往后放。排序后先把正的放进去。

然后考虑往前面放负的。后面所有都会右移一位。因此记录后面所有数的和。如果大于当前负数的绝对值则放入负数

#include<cstdio>
#include<algorithm>
using namespace std;
struct num
{
int v,c;
}a[1001];
inline bool cmp(num x,num y)
{
return x.v<y.v;
}
int main()
{
int T;
scanf("%d",&T);
while(T>0)
{
T--;
int n;
scanf("%d",&n);
int i;
for(i=1;i<=n;i++)
scanf("%d%d",&a[i].v,&a[i].c);
sort(a+1,a+1+n,cmp);
int ans=0,d=1,la=-1,sum=0;
for(i=1;i<=n;i++)
{
if(a[i].v<0)
continue;
if(la==-1)
la=i-1;
while(a[i].c>0)
{
ans+=a[i].v*d;
sum+=a[i].v;
a[i].c--;
d++;
}
}
for(i=la;i>=1;i--)
{
while(a[i].c>0)
{
sum+=a[i].v;
if(sum<0)
break;
ans+=sum;
a[i].c--;
d++;
}
if(sum<0)
break;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  贪心