您的位置:首页 > 其它

POJ 1797 Heavy Transportation (最短路)

2017-03-19 20:03 381 查看
Background

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed
on which all streets can carry the weight.

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's
place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers
specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer.
Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4


题目大意:有n个城市,m条道路,在每条道路上有一个承载量,现在要求从1到n城市最大承载量,而最大承载量就是从城市1到城市n所有通路上的最大承载量

注意输出的格式,两个数据中有间隔。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
using namespace std;
const int N = 1111;
const int inf = 0x3f3f3f3f;
struct P
{
int v,c;
P(int v,int c):v(v),c(c){}
P(){}
bool operator < (const P&t1) const
{
return c<t1.c;
}
};
priority_queue<P>que;
vector<P>vec
;
int vis
;
int dp
;
int main()
{
int T,i,j,n,m;
int u,v,c;
scanf("%d",&T);
for(int _=1;_<=T;_++) {
if(_!=1) printf("\n");
scanf("%d%d",&n,&m);
for(i=0;i<=n;i++) vec[i].clear();
while(!que.empty()) que.pop();
memset(vis,0,sizeof(vis));
fill(dp,dp+n+1,-inf);
while(m--) {
scanf("%d%d%d",&u,&v,&c);
vec[v].push_back(P(u,c));
vec[u].push_back(P(v,c));
}
dp[1]=inf;
que.push(P(1,inf));
while(!que.empty()) {
P p = que.top();
que.pop();
if(vis[p.v]) continue;
vis[p.v]=1;
for(i=0;i<vec[p.v].size();i++) {
P tmp = vec[p.v][i];
if(dp[tmp.v]<min(dp[p.v],tmp.c)) {
dp[tmp.v]=min(dp[p.v],tmp.c);
que.push(P(tmp.v,dp[tmp.v]));
}
}
}
printf("Scenario #%d:\n",_);
printf("%d\n",dp
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: