您的位置:首页 > 其它

HDU 3555 Bomb

2017-03-19 16:14 162 查看

Bomb

[align=left]Problem Description[/align]
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the
power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

[align=left]Input[/align]
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

[align=left]Output[/align]
For each test case, output an integer indicating the final points of the power.

[align=left]Sample Input[/align]

3
1
50
500

 
[align=left]Sample Output[/align]

0
1
15

题意:给出一个数,找到0到这个数之间包含49的数的个数,比如说500的,就是这些数"49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",总共15个


这道题算是基础数位DP,我依照这道题做一个基本代码研究

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
__int64 dp[23][3];
void Init()
{
int i;
memset(dp,0,sizeof(dp));
dp[0][2]=1;
for(i=1; i<22; i++)
{
dp[i][0]=dp[i-1][0]*10+dp[i-1][1];
dp[i][1]=dp[i-1][2];
dp[i][2]=dp[i-1][2]*10-dp[i-1][1];
}
}
int main()
{
int i,j,Case;
__int64 num;
char c[30];
int a[30];
Init();
scanf("%d",&Case);
while(Case--)
{
scanf("%I64d",&num);
num++;
int len=0;
while(num)
{
a[++len]=num%10;
num/=10;
}

a[len+1]=0;
bool flag=0;
__int64 sum=0;
for(i=len; i>0; i--)
{
sum+=dp[i-1][0]*a[i];
if(flag)
sum+=dp[i-1][2]*a[i];
if(!flag&&a[i]>4)
sum+=dp[i-1][1];
if(a[i]==9&&a[i+1]==4)
flag=1;
}
printf("%I64d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM