您的位置:首页 > 其它

poj 1611 The Suspects(启发式式合并,并查集)

2017-03-19 11:53 381 查看
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student
is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the
number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1


此题就是求0号同学和其他的同学是否在一个集合,在一个集合里就求出 包含0同学集合中的所有的同学,在这里我用的 启发式合并集合

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<ctype.h>
#include<math.h>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<string>
#include<iostream>
#include<algorithm>
#include<utility>
#include<iomanip>
#include<time.h>
typedef long long ll;
const double Pi = acos(-1.0);
const int N = 1e6+10, M = 1e3+20, mod = 1e9+7, inf = 2e9+10;
const double e=2.718281828459 ;
const double esp=1e-9;
using namespace std;
int n,m;
int Father[30005];
int rank[30005];
int Find(int x)
{
if(x!=Father[x])
return Father[x]=Find(Father[x]);
else return Father[x];
}
void Union(int x,int y)
{
int a=Find(x);
int b=Find(y);
if(a==b)
return ;
if(rank[a]<rank[b])
{
Father[b]=a;
}
else
{
if(rank[a]==rank[b]) rank[b]++;
Father[a]=b;
}
}
int main()
{
while(~scanf("%d%d",&n,&m),n||m)
{
if(m==0)
{
printf("1\n");
continue;
}
for(int i=0; i<n; i++)
{
Father[i]=i;
rank[i]=0;
}
int k,x,y;
for(int i=0; i<m; i++)
{
scanf("%d",&k);
scanf("%d",&x);
for(int i=1; i<k; i++)
{
scanf("%d",&y);
Union(x,y);
x=y;
}
}
int sum=0;
for(int i=0; i<n; i++)
{
if(Find(i)==Find(0))//此处写Find(i)==Find(0)更新了i的更节点
sum++;
}
printf("%d\n",sum );
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: