您的位置:首页 > 其它

HDU 4221 Greedy?

2017-03-17 22:00 155 查看


Greedy?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2261    Accepted Submission(s): 765


Problem Description

iSea is going to be CRAZY! Recently, he was assigned a lot of works to do, so many that you can't imagine. Each task costs Ci time as least, and the worst news is, he must do this work no later than time Di!

OMG, how could it be conceivable! After simple estimation, he discovers a fact that if a work is finished after Di, says Ti, he will get a penalty Ti - Di. Though it may be impossible for him to finish every task before its deadline, he wants the maximum penalty
of all the tasks to be as small as possible. He can finish those tasks at any order, and once a task begins, it can't be interrupted. All tasks should begin at integral times, and time begins from 0.

 

Input

The first line contains a single integer T, indicating the number of test cases.

Each test case includes an integer N. Then N lines following, each line contains two integers Ci and Di.

Technical Specification

1. 1 <= T <= 100

2. 1 <= N <= 100 000

3. 1 <= Ci, Di <= 1 000 000 000

 

Output

For each test case, output the case number first, then the smallest maximum penalty.

 

Sample Input

2
2
3 4
2 2
4
3 6
2 7
4 5
3 9

 

Sample Output

Case 1: 1
Case 2: 3

 

Author

iSea@WHU

 

Source

首届华中区程序设计邀请赛暨第十届武汉大学程序设计大赛

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  4224 4223 4219 4218 4217 

 

Statistic | Submit | Discuss | Note

找罚款最大的最小值,对截至时间升序排序:

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
struct time{
int s,e;
}ti[100010];
int cmp(const time &a,const time &b){
return a.e<b.e;
}
int main(){
__int64 sum,num;
int t,k,n,i;
scanf("%d",&t);
for(k=1;k<=t;k++){
scanf("%d",&n);
for(i=0;i<n;i++){
scanf("%d%d",&ti[i].s,&ti[i].e);
}
sort(ti,ti+n,cmp);
num=0; sum=0;
for(i=0;i<n;i++){
num+=ti[i].s;
if(sum<num-ti[i].e){
sum=num-ti[i].e;
}
}
printf("Case %d: %I64d\n",k,sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: