您的位置:首页 > 产品设计 > UI/UE

hdu 1110 Equipment Box(数学)

2017-03-17 21:40 330 查看

Equipment Box

Problem Description

There is a large room in the Pyramid called Room-of-No-Return. Its floor is covered by rectangular tiles of equal size. The name of the room was chosen because of the very high number of traps and mechanisms in it. The ACM group has spent several years studying the secret plan of this room. It has made a clever plan to avoid all the traps. A specially trained mechanic was sent to deactivate the most feared trap called Shattered Bones. After deactivating the trap the mechanic had to escape from the room. It is very important to step on the center of the tiles only; he must not touch the edges. One wrong step and a large rock falls from the ceiling squashing the mechanic like a pancake. After deactivating the trap, he realized a horrible thing: the ACM plan did not take his equipment box into consideration. The box must be laid onto the ground because the mechanic must have both hands free to prevent contact with other traps. But when the box is laid on the ground, it could touch the line separating the tiles. And this is the main problem you are to solve.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input. Each test case consists of a single line. The line contains exactly four integer numbers separated by spaces: A, B, X and Y. A and Bindicate the dimensions of the tiles, X and Y are the dimensions of the equipment box (1 <= A, B, X, Y <= 50000).

Output

Your task is to determine whether it is possible to put the box on a single tile – that is, if the whole box fits on a single tile without touching its border. If so, you are to print one line with the sentence “Escape is possible.”. Otherwise print the sentence “Box cannot be dropped.”.

Sample Input

2

10 10 8 8

8 8 10 10

Sample Output

Escape is possible.

Box cannot be dropped.

参考博客:http://blog.csdn.net/were__wolf/article/details/16105527



ps:主要是斜着放没有想出来

斜着的话h要小于a

代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;

int judge(double a,double b,double x,double y)
{
double k=sqrt(x*x+y*y);
double angle=acos(y/k)-acos(b/k);
double m=x*cos(angle)+y*sin(angle);
if(m<a)
return 1;
return 0;
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
double a,b,x,y;
scanf("%lf%lf%lf%lf",&a,&b,&x,&y);
if(a<b)
swap(a,b);
if(x<y)
swap(x,y);
if(a>x&&b>y)//长和宽均满足条件
printf("Escape is possible.\n");
else if(b<=y||a*b<=x*y)//宽较小或者是面积较小
printf("Box cannot be dropped.\n");
else
{
if(judge(a,b,x,y))
printf("Escape is possible.\n");
else
printf("Box cannot be dropped.\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: