您的位置:首页 > 其它

HDU 2222 AC自动机 模板

2017-03-17 18:23 453 查看
Keywords Search

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 60573 Accepted Submission(s): 19961

Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.

Wiskey also wants to bring this feature to his image retrieval system.

Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1

5

she

he

say

shr

her

yasherhs

Sample Output

3

Author

Wiskey

AC自动机模板,大概就是构造一个类似KMP的next数组的fail指针.然后每次匹配失败时候直接转跳fail指针所指的位置.(之前的模板有点问题,已经修正)

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 5e5+100;
int val[maxn],go[maxn][26],fail[maxn],rec[maxn],sum[maxn];
struct ac_auto
{
int root,cnt;
int create()
{
cnt++;
memset(go[cnt],0,sizeof(go[cnt]));
val[cnt]=0;
return cnt;
}
void init()
{
cnt=0;
root=create();
}
void Insert(char s[])
{
int len=strlen(s);
int now=root;
for (int i=0;i<len;i++)
{
int ch=s[i]-'a';
if (!go[now][ch]) go[now][ch]=create();
now=go[now][ch];
}
val[now]+=1;
}
void build()
{
static queue<int>q;
while (!q.empty()) q.pop();
q.push(root);
while (!q.empty())
{
int u=q.front(); q.pop();
for (int i=0;i<26;i++)
{
if (go[u][i]){
int y=go[u][i],v=fail[u];
for (;v&&go[v][i]==0;v=fail[v]);
fail[y]=v?go[v][i]:root;
sum[y]=val[y]+sum[fail[y]];
q.push(y);
}
}
}
}
int get(int x)
{
int res=0;
while (x)
{
res+=val[x];
val[x]=0;
x=fail[x];
}
return res;
}
int match(char s[])
{
int point=1,res=0;
int now=root,len=strlen(s);
for (int i=0;i<len;i++)
{
int ch=s[i]-'a';
for (;now&&!go[now][ch];now=fail[now]);
now=now?go[now][ch]:root;
if(val[now]) rec[now]=1;
res+=get(now);
}
return res;
}
}ac;
char st[1000005];
int main()
{

int T,N;
scanf("%d",&N);
while (N--){
scanf("%d",&T);
ac.init();
while (T--)
{
char str[100];
scanf("%s",str);
ac.Insert(str);
}
ac.build();
scanf("%s",st);
printf("%d\n",ac.match(st));
}
//printf("%d\n",ac.bfs());
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: