您的位置:首页 > 其它

Hat's Fibonacci hdu 1250

2017-03-17 13:29 393 查看
Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.

F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)

Your task is to take a number as input, and print that Fibonacci number.

Input

Each line will contain an integers. Process to end of file.

Output

For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646

Note:

No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<stdio.h>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std;

const int INF=1e9+7;
const int maxn=2010;

int a[10000][260]= {0};  //每个元素可以存储8位数字,所以2005位可以用260个数组元素存储。
int main()
{
int i,j,n;
a[1][0]=1;      //赋初值
a[2][0]=1;
a[3][0]=1;
a[4][0]=1;
for(i=5; i<10000; i++)
{
for(j=0; j<260; j++)
a[i][j]+=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
for(j=0; j<260; j++)              //每八位考虑进位。
if(a[i][j]>100000000)
{
a[i][j+1]+=a[i][j]/100000000;
a[i][j]=a[i][j]%100000000;
}
}
while(scanf("%d",&n)!=EOF)
{
for(j=259; j>=0; j--)
if(a
[j]!=0) break;      //不输出高位的0
printf("%d",a
[j]);
for(j=j-1; j>=0; j--)
printf("%08d",a
[j]);     //每个元素存储了八位数字,所以控制输出位数为8,左边补0
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: