您的位置:首页 > 其它

hdu 1250 Hat's Fibonacci(高精度)

2017-03-17 10:28 465 查看
[align=left]Problem Description[/align]
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.

F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)

Your task is to take a number as input, and print that Fibonacci number.

 

[align=left]Input[/align]
Each line will contain an integers. Process to end of file.

 

[align=left]Output[/align]
For each case, output the result in a line.
 

[align=left]Sample Input[/align]

100

 

[align=left]Sample Output[/align]

4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<string>
#include<queue>
#include<map>
#include<stack>
#include<math.h>
#include<stdlib.h>
using namespace std;
int a[10000][260];
int main()
{
int i,j,n;
a[1][0]=1;
a[2][0]=1;
a[3][0]=1;
a[4][0]=1;
for(int i=5;i<10000;i++)
{
for(int j=0;j<260;j++)
{
a[i][j]+=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
if(a[i][j]>100000000)
{
a[i][j+1]+=a[i][j]/100000000;
a[i][j]=a[i][j]%100000000;
}
}
}
while(scanf("%d",&n)!=EOF)
{
for(j=259;j>=0;j--)
{
if(a
[j]!=0) break;
}
printf("%d",a
[j]);
for(i=j-1;i>=0;i--)
{
printf("%08d",a
[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: