您的位置:首页 > 其它

Problem j-10 IBM Minus One

2017-03-16 16:04 239 查看
Description

You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the
ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)

After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace
every letter in the word HAL by its successor in the alphabet, you get ... IBM.

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

Input

The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

Output

For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.

Print a blank line after each test case.

Sample Input

2

HAL

SWERC

Sample Output

String #1

IBM

String #2

TXFSD

题目介绍

把一个字符串(由大写字母组成)转换成另一个字符串,每个字符转换为下一个字符

解题思路

首先解决字符串的输出格式问题,每行输出钱都要先输出“String #”行 每个测试结束后输出一个空行,剩下的就是正常的输入输出,注意特例是Z对应的是A

源代码

#include<bits/stdc++.h>

using namespace std;

int main()

{

        int n;

        string s;

        cin>>n;

        for(int i=0;i<n;i++)

        {

                cin>>s;

                cout<<"String #"<<i+1<<endl;

                for(int j=0;j<s.size();j++)

                {

                        cout<<(s[j]!='Z'?char(s[j]+1):'A');

                }

                cout<<endl;

                cout<<endl;//要产生一行空行

        }

        return 0;

}

细节决定成败,有的时候往往就是在一些小的细节处出问题导致A不了题,比如一个大小写的地方没注意,谨记
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: