您的位置:首页 > 其它

L2-012. 关于堆的判断

2017-03-15 10:08 197 查看
将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

“x is the root”:x是根结点;

“x and y are siblings”:x和y是兄弟结点;

“x is the parent of y”:x是y的父结点;

“x is a child of y”:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(<= 1000)和M(<= 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出“T”,否则输出“F”。
输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:
F
T
F
T

主要是思考堆是如何插入的。

代码:

#include<iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <map>
using namespace std;
int qq[1050];
map<int,int>q1;
int dfs(int x){
if(x==1)return 0;
if(qq[x]<qq[x/2]){
swap(qq[x],qq[x/2]);
q1[qq[x/2]]=x/2;
q1[qq[x]]=x;
dfs(x/2);
}
}
char b[100];
int main(){
//freopen("in.txt","r",stdin);
int i,j,k,l,f1,f2,f3,t1,t2,t3;
int n,m;
cin >> n >>m ;
memset(qq,0,sizeof(qq));
q1.clear();
for(i=1;i<=n;i++){
cin >> qq[i];
q1[qq[i]]=i;
dfs(i);
}
//for(i=1;i<=n;i++)
// cout << qq[i] << endl;
for(i=1;i<=m;i++){
cin >>f1 >>b;
// cout << f1 << " 666 " << b << endl;
if(b[0]=='a'){
scanf("%d are siblings",&f2);
if(q1[f1]/2==q1[f2]/2)
cout << "T" << endl;
else
cout << "F" << endl;
}else if(b[0]=='i'){
cin >> b;
if(b[0]=='a'){
scanf(" child of %d",&f2);
if(q1[f1]/2==q1[f2])
cout << "T" <<endl;
else
cout << "F" << endl;
}else{
cin >>b;
// cout << "----" << b<< endl;
if(b[0]=='r'){
if(q1[f1]==1)
cout << "T" << endl;
else
cout << "F" << endl;
}else{
scanf(" of %d",&f2); //1、前面用cin的输入了s1后,后面如果使用scanf要留有空格
//cout << "parent=== " << f2<< endl;
if(q1[f2]/2==q1[f1])
cout << "T" <<endl;
else
cout << "F" << endl;
}
}
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: