您的位置:首页 > 其它

九度OJ1094解题报告

2017-03-14 18:12 295 查看
时间限制:1 秒内存限制:32 兆特殊判题:否提交:1626解决:895

题目描述:

    Finding all occurrences of a pattern in a text is a problem that arises frequently in text-editing programs. 

    Typically,the text is a document being edited,and the pattern searched for is a particular word supplied by the user.  

    We assume that the text is an array T[1..n] of length n and that the pattern is an array P[1..m] of length m<=n.We further assume that the elements of P and  T are all alphabets(∑={a,b...,z}).The character arrays P and T are often called strings of characters.
 

    We say that pattern P occurs with shift s in the text T if 0<=s<=n and T[s+1..s+m] = P[1..m](that is if T[s+j]=P[j],for 1<=j<=m).  

    If P occurs with shift s in T,then we call s a valid shift;otherwise,we calls a invalid shift. 

    Your task is to calculate the number of vald shifts for the given text T and p attern P.

输入:

   For each case, there are two strings T and P on a line,separated by a single space.You may assume both the length of T and P will not exceed 10^6. 

输出:

    You should output a number on a separate line,which indicates the number of valid shifts for the given text T and pattern P.

样例输入:

abababab abab

样例输出:
3

源代码一:

#include <iostream>

#include <string>

#include <map>

using namespace std;

int main(){

string str,ch;

while(cin>>str>>ch){

    int strlen=str.length(),chlen=ch.length();

    int i,j,k,flag=1,count1=0;

    for(i=0;i<strlen;i++){

            j=0;

            while(str[i+j]==ch[j]){

                j++;

                 if(j==chlen) {

                count1++;

                break;

    }

            }

    }

    cout<<count1<<endl;

}

return 0;

}

源代码二:

#include <iostream>

#include <string>

#include <map>

 using namespace std;

int main(){

string str,ch;

while(cin>>str>>ch){

    int strlen=str.length(),chlen=ch.length();

    int i,j,k,flag=1,count1=0;

    for(i=0;i<strlen;i++){

            j=0;

            while(str[i+j]==ch[j]){

                j++;

            }

        if(j>=chlen) {

                count1++;

    }

    }

    cout<<count1<<endl;

}

return 0;

}

/**************************************************************
Problem: 1094
User: kaoyandaren123
Language: C++
Result: Accepted
Time:130 ms
Memory:3052 kb

****************************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: