您的位置:首页 > 其它

ACM刷题之Poj————Wireless Network

2017-03-14 15:43 106 查看
Wireless Network

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 25998 Accepted: 10825
Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by
one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the
communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers
xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 

1. "O p" (1 <= p <= N), which means repairing computer p. 

2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output
FAIL
SUCCESS




并查集的简单应用

这里要先设定一个vis数组,当这台电脑修理过,就更新下访问的状态。

然后遍历各个访问过的电脑 看是否属于同一个集合就好了。

注意,算距的时候不能算根节点到当前电脑的距离!!!

下面是ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<string>
#include<iostream>
using namespace std;
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int N=2e5+7;

typedef struct jf{

int x,y,pre;
}jf;

jf a[22222];

bool vis[22222];
int n,i,j,k;

int finds(int x)
{
if(x==a[x].pre)
return a[x].pre;
else{ return finds(a[x].pre);}
}

void check(int a,int b)
{
int p1=finds(a);
int p2=finds(b);
if(p1==p2) printf("SUCCESS\n");
else printf("FAIL\n");
}

void join(int e,int r)
{

int p1=finds(e);
int p2=finds(r);

if(p1==p2) return;
else
{
if((a[e].x-a[r].x)*(a[e].x-a[r].x)+(a[e].y-a[r].y)*(a[e].y-a[r].y)<=k*k)
{

a[p2].pre=p1;
}

}
}

int main()
{
//freopen("f:/input.txt", "r", stdin);
int m;
char c;
CLR(vis,false);
scanf("%d%d",&n,&k);
for(i=1;i<=n;i++)
{
scanf("%d%d",&a[i].x,&a[i].y);
a[i].pre=i;
}
while(scanf("\n%c",&c)!=EOF)
{
if(c=='O')
{

scanf("%d",&m);
vis[m]=true;
for(i=1;i<=n;i++)
{
if(vis[i]&&i!=m)
{
join(i,m);
}
}

}else if(c=='S'){
int q,w;
scanf("%d%d",&q,&w);
check(q,w);
}else	break;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: