您的位置:首页 > 其它

POJ_2377_Bad Cowtractors_最大生成树

2017-03-14 11:49 429 查看
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000)

 barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M

 (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route

  has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting

   the network; he doesn't even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide

on a set of connections to install so that (i) the total cost of these connections is as large as possible,

 (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn

  via a path of installed connections), and (iii) so that there are no cycles among the connections (which

  Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of

  connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection

route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns.

 If it is not possible to connect all the barns, output -1.

Sample Input

5 8

1 2 3

1 3 7

2 3 10

2 4 4

2 5 8

3 4 6

3 5 2

4 5 17

Sample Output

42

题意:求出不成环又使所有点连通的最大权值的和

#include <stdio.h>
#include <stdlib.h>
int s[1005];
int n,m;
struct Node
{
int x;
int y;
int w;
}a[20005];
int min(int a,int b)
{
return a>b?b:a;
}
int cmp(const void *a,const void *b)
{
Node *c = (Node *)a;
Node *d = (Node *)b;
if(c->w>d->w)
{
return -1;
}
else
{
return 1;
}
}
int find(int x)
{
if(x==s[x])
{
return x;
}
else
{
return s[x] = find(s[x]);
}
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,j;
for(i=0;i<m;i++)
{
scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].w);
}
qsort(a,m,sizeof(a[0]),cmp);
for(i=1;i<=n;i++)
{
s[i] = i;
}
int count = 0;
int sum = 0;
for(i=0;i<m;i++)
{
int _a = find(a[i].x);
int _b = find(a[i].y);
if(_a!=_b)
{
s[_a] = _b;
sum+= a[i].w;
count++;
}
if(count==n-1)
{
break;
}
}
int ans = 0;
for(i=1;i<=n;i++)
{
if(s[i]==i)
{
ans++;
}
}
if(ans==1)
{
printf("%d\n",sum);
}
else
{
printf("-1\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: