您的位置:首页 > 其它

HDU 1395

2017-03-13 22:21 148 查看

 

2^x mod n = 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16883    Accepted Submission(s): 5262


Problem Description Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.  

 

Input One positive integer on each line, the value of n.  

 

Output If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.  

 

Sample Input 2 5  

 

Sample Output 2^? mod 2 = 1 2^4 mod 5 = 1  
#include "stdio.h"
int main()
{
int n;
while(~scanf("%d",&n)&&n){
if(n==1||n%2==0){
printf("2^? mod %d = 1\n",n);
continue;
}
else{
int x=1,mut=2;
mut%=n;
while(mut!=1){
x++;
mut=mut*2%n;
}
printf("2^%d mod %d = 1\n",x,n);
}
}
return 0;
}

开始时Time Limit Exceeded

改进1.n==1情况  2.循环式取余,减少运算量

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: