您的位置:首页 > 其它

Party All the Time(三分)

2017-03-13 21:13 316 查看
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home
if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 

Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

InputThe first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x ii<=x i+1i+1for
all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )
OutputFor each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
Sample Input
1
4
0.6 5
3.9 10
5.1 7
8.4 10


Sample Output
Case #1: 832

这道我刚开始是分成均等的三份进行三分,结果超时,然后试了试二分中的二分的三分,过了。看来还是这个快啊,下面是正确代码!!!!

#include <iostream>

#include <cstring>

#include <cstdio>

using namespace std;

const double eps=1e-12;

int t;

/*struct Node

{

    double x;

    double w;

}nde[50010];*/

double a[405];

double cal(double xx)

{

    double res=0;

    for(int i=0;i<=t;i++)

    {

        double d=xx-a[i];

        if(d<0)

        d=d*(-1);

        res+=d;

    }

    return res;

}

int main()

{

    while(scanf("%d",&t)!=-1)

    {

        for(int i=1;i<=t;i++)

        scanf("%lf",&a[i]);

        double mid,midd;

        double l=a[1];

        double r=a[t];

        while(r-l>eps)

        {

            mid=(r+l)/2;

            midd=(r+mid)/2;

            if(cal(mid)<cal(midd))

            r=midd;

            else

            l=mid;

        }

        double g=cal(l);

        double h=cal(r);

        if(g<h)

        printf("%.10f\n",g);

        else

        printf("%.10f\n",h);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: