您的位置:首页 > 大数据 > 人工智能

POJ 2246 Matrix Chain Multiplication 栈

2017-03-13 20:10 357 查看

Matrix Chain Multiplication

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 2416 Accepted: 1497

Description

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices.

Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.

There are two different strategies to compute A*B*C, namely (A*B)C and A(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line }

Line = Expression

Expression = Matrix | “(” Expression Expression “)”

Matrix = “A” | “B” | “C” | … | “X” | “Y” | “Z”

Output

For each expression found in the second part of the input file, print one line containing the word “error” if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9

A 50 10

B 10 20

C 20 5

D 30 35

E 35 15

F 15 5

G 5 10

H 10 20

I 20 25

A

B

C

(AA)

(AB)

(AC)

(A(BC))

((AB)C)

(((((DE)F)G)H)I)

(D(E(F(G(HI)))))

((D(EF))((GH)I))

Sample Output

0

0

0

error

10000

error

3500

15000

40500

47500

15125

题目链接:http://poj.org/problem?id=2246

题意:

给你一堆矩阵,然后给你一堆表达式,求每个表达式相乘所需要的加法次数。


题解:

栈的经典题目,计算两个矩阵相乘的加法次数为ma.a*ma.b*mb.a。
由于矩阵的总个数不超过26个,是以单个字母命名的,可以用字母-'A'作为下标,
以便快速地查找对应矩阵。
将遇到的矩阵入栈,遇到')'时取出两个矩阵,计算加法次数后,将生成的新矩阵入栈。不符合乘法条件,直接error。
计算的时候,栈顶的第一个矩阵是乘法AB时右边的B矩阵,而栈顶的第一个矩阵是乘法AB左边的A矩阵.


//#include <bits/stdc++.h>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<string>
#include<stack>
#include<queue>
#define INF 0xffffffff
using namespace std;
typedef long long ll;

const int maxn = 30;
struct Matrix{
ll a, b;
Matrix(){}
Matrix(ll a, ll b):a(a), b(b){}
}m[maxn];

char expr[1000];
stack<Matrix> s;

int main(){
int n;
while(scanf("%d", &n) == 1 && n){
memset(m, 0, sizeof(m));
for(int i=0; i<n; i++){
char c;
ll a, b;
scanf("\n%c%lld%lld", &c, &a, &b);
m[c-'A'].a = a;
m[c-'A'].b = b;
}
while(scanf("%s", expr) == 1){
ll ans = 0;
int flag = 0;
while(!s.empty()){
s.pop();
}
for(int i=0; i<strlen(expr); i++){
if(isalpha(expr[i])){
Matrix ma = m[expr[i]-'A'];
s.push(ma);
}
else if(expr[i] == ')'){
Matrix ma = s.top();
s.pop();
Matrix mb = s.top();
s.pop();
if(mb.b == ma.a){
ans += mb.a*mb.b*ma.b;
Matrix mc(mb.a, ma.b);
s.push(mc);
}
else{
flag = 1;
break;
}
}
}
if(flag){
printf("error\n");
}
else{
printf("%lld\n", ans);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  矩阵乘法