您的位置:首页 > 其它

hdu 3792 Twin Prime Conjecture 浙大复试上机题 水题

2017-03-11 22:37 531 查看

Twin Prime Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3211    Accepted Submission(s): 1138


[align=left]Problem Description[/align]
If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that "There are infinite consecutive primes differing by 2".

Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
 

[align=left]Input[/align]
Your program must read test cases from standard input.

The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
 

[align=left]Output[/align]
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
 

[align=left]Sample Input[/align]

1
5
20
-2

 

[align=left]Sample Output[/align]

0
1
4

 

用筛法求素数,然后用树状数组记录区间的孪生素数对。

#include<stdio.h>

#define MAX 100100

int ta[MAX*10];
int p[MAX] ;

int lowbit(int x)
{
return x&(-x) ;
}

int sum(int x)
{
int k = x ,sum = 0;
while(k)
{
sum += ta[k] ;
k -= lowbit(k) ;
}
return sum ;
}

void add(int x , int c)
{
while(x<MAX*10)
{
ta[x] += c ;
x += lowbit(x) ;
}
}

void getPrime()
{
for(int i=2 ; i < MAX ;++i)
{
for(int j = 2 ; i*j<=MAX ; ++j )
{
p[i*j] = true ;
}
}
}

void init()
{
getPrime();
for(int i = 4 ; i < MAX ; ++i)
{
if(!p[i-2]&&!p[i])
{
add(i,1) ;
}
}
}

int main()
{
int n;
init() ;
while(~scanf("%d",&n) && n>=0)
{
printf("%d\n",sum(n)) ;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息