您的位置:首页 > 其它

hdu 4911 Inversion (归并排序)

2017-03-11 21:34 369 查看
Problem Description

bobo has a sequence a1,a2,…,an. He is allowed to swap two adjacent numbers for no more than k times.

Find the minimum number of inversions after his swaps.

Note: The number of inversions is the number of pair (i,j) where 1≤i<j≤n and ai>aj.

 

Input

The input consists of several tests. For each tests:

The first line contains 2 integers n,k (1≤n≤105,0≤k≤109). The second line contains n integers a1,a2,…,an (0≤ai≤109).

 

Output

For each tests:

A single integer denotes the minimum number of inversions.

 

Sample Input

3 1
2 2 1
3 0
2 2 1

 

Sample Output

1
2

 

Author

Xiaoxu Guo (ftiasch)

 

Source

2014 Multi-University Training Contest 5

题意:给出n个数,每次可以交换相邻的两个数,最多交换k次,求交换后最小的逆序数是多少。

思路:如果逆序数大于0,则存在1 ≤ i < n,使得交换ai和ai+1后逆序数减1。

  归并排序时稳定的排序,能较快求出逆序数;

先贴别人写得规范点的代码:

#include<stdio.h>
#include<string.h>
#define N 100005
__int64 cnt, k;
int a
,c
;
//归并排序的合并操作
void merge(int a[], int first, int mid, int last, int c[])
{
int i = first, j = mid + 1;
int m = mid, n = last;
int k = 0;
while(i <= m || j <= n)
{
if(j > n || (i <= m && a[i] <= a[j]))
c[k++] = a[i++];
else
{
c[k++] = a[j++];
cnt += (m - i + 1);
}
}
for(i = 0; i < k; i++)
a[first + i] = c[i];
}
//归并排序的递归分解和合并
void merge_sort(int a[], int first, int last, int c[])
{
if(first < last)
{
int mid = (first + last) / 2;
merge_sort(a, first, mid, c);
merge_sort(a, mid+1, last, c);
merge(a, first, mid, last, c);
}
}
int main()
{
int n;
while(~scanf("%d%I64d",&n,&k))
{
memset(c, 0, sizeof(c));
cnt = 0;
for(int i = 0; i < n; i++)
scanf("%d", &a[i]);
merge_sort(a, 0, n-1, c);
if(k >= cnt) cnt = 0;
else cnt -= k;
printf("%I64d\n",cnt);
}
}

自己代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=100005;
__int64 a
,c
;
__int64 cnt;
void _merge(__int64 l,__int64 mid,__int64 r)
{
__int64 k=0;
__int64 first=l;
__int64 dx=mid,dy=mid+1;
while(l<=dx||dy<=r)
{
if(dy>r||(l<=dx&&a[l]<=a[dy]))
c[k++]=a[l++];
else
{
c[k++]=a[dy++];
cnt+=(mid-l+1);
}
}
for(int i = 0; i < k; i++)
a[first + i] = c[i];
}
void merge_sort(__int64 l,__int64 r)
{
if(l<r)
{
__int64 mid=(l+r)/2;
merge_sort(l,mid);
merge_sort(mid+1,r);
_merge(l,mid,r);
}
}
int main()
{
__int64 n;
__int64 k;
while(~scanf("%I64d%I64d",&n,&k))
{
for(int i=0;i<n;i++)
scanf("%I64d",&a[i]);
cnt=0;
merge_sort(0,n-1);
if(cnt<=k) cnt=0;
else cnt=cnt-k;
printf("%I64d\n",cnt);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: