您的位置:首页 > 其它

CSU 1809: Parenthesis【前缀和】

2017-03-11 19:07 477 查看


1809: Parenthesis

Submit    
Status    Time
Limit: 5 Sec |
Memory Limit: 128 Mb |
Submitted: 1111 |
Solved: 317


Description

Bobo has a balanced parenthesis sequence P=p1 p2…pn of
length n and q questions.
The i-th question is whether P remains balanced after pai and pbi  swapped.
Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists balanced parenthesis sequence A,B such that S=AB;
3. or there exists balanced parenthesis sequence S' such that S=(S').


Input

The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤105,1≤q≤105).
The second line contains n characters p1 p2…pn.
The i-th of the last q lines contains 2 integers ai,bi (1≤ai,bi≤n,ai≠bi).


Output

For each question, output "Yes" if P remains balanced, or "No" otherwise.


Sample Input

4 2
(())
1 3
2 3
2 1
()
1 2



Sample Output

No
Yes
No



Hint


Source

湖南省第十二届大学生计算机程序设计竞赛

#include<iostream>
#include<cstdio>
#include<math.h>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<list>
#include<vector>
#include<sstream>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define ms(x,y)memset(x,y,sizeof(x))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ll long long
const int INF=0x7ffffff;

const int M=1e5+10;
int i,j,k,n,m,q;
char s[M];
int a[M];
int b[M];

int main()
{
while(~scanf("%d%d",&n,&q)){
ms(a,0),ms(b,0);
getchar();
for(i=1;i<=n;i++){
scanf("%c",&s[i]);
if(s[i]=='(')a[i]=1;
else a[i]=-1;
b[i+1]=b[i]+a[i];
}
while(q--){
int x,y;
scanf("%d%d",&x,&y);
if(s[x]==s[y]){
printf("Yes\n");continue;
}
if(x>y)swap(x,y);
int flag=0;
for(i=x+1;i<=y;i++){
b[i]=b[i]-a[x]+a[y];
if(b[i]<0)flag=1;
}
if(b[y]+a[x]<0)flag=1;
for(i=x+1;i<=y;i++){
b[i]=b[i]+a[x]-a[y];
}
if(flag)printf("No\n");
else printf("Yes\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: