您的位置:首页 > 其它

【HDU 5666 Segment】+ 俄罗斯乘法

2017-03-10 22:14 330 查看
Segment

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1771 Accepted Submission(s): 655

Problem Description

Silen August does not like to talk with others.She like to find some interesting problems.

Today she finds an interesting problem.She finds a segment x+y=q.The segment intersect the axis and produce a delta.She links some line between (0,0) and the node on the segment whose coordinate are integers.

Please calculate how many nodes are in the delta and not on the segments,output answer mod P.


Input

First line has a number,T,means testcase number.

Then,each line has two integers q,P.

q is a prime number,and 2≤q≤1018,1≤P≤1018,1≤T≤10.


Output

Output 1 number to each testcase,answer mod P.

Sample Input

1

2 107

Sample Output

0

Source

BestCoder Round #80

线段上的数 = gcd(x,q - x)= gcd(x,q) = 1,所有在x + y = q的线段上的点与(0,0)连接时,不会有三角形内部的点落在上面~而三角形内部的点 == (q - 1) * (q - 2) / 2;

两个很大的数直接相乘结果会爆 LL ,需要用到 俄罗斯乘法,和快速幂类似~

俄罗斯乘法是一种计算两数相乘的算法。

举例如下:

计算 35*72

过程

35 72

17 144

8 288

4 576

2 1152

1 2304

从上到下,对每一行,若左边的数字若为奇数,则将右边的数字取出,累加。

72+144+2304=2520

累加的结果2520即为乘积。

AC代码:

#include<cstdio>
typedef long long LL;
LL p,q;
LL els(LL a ,LL b){
LL ans = 0;
while(a){
if(a & 1)
ans = (ans + b) % p;
a /= 2,b = b * 2 % p;
}
return ans;
}
int main()
{
int T;
scanf("%d",&T);
while(T--){
scanf("%lld %lld",&q,&p);
printf("%lld\n",els((q - 2) % p,(q - 1) / 2 % p));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: