您的位置:首页 > 其它

HDU 4730 We Love MOE Girls

2017-03-10 21:04 417 查看


We Love MOE Girls

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3312    Accepted Submission(s): 1871


Problem Description

Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.

In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".

There are two situations:

If a sentence ends with "desu", she changes "desu" int
4000
o "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.

Given an original sentence, what will it sound like aften spoken by Nanako?

 

Input

The first line has a number T (T <= 1000) , indicating the number of test cases.

For each test case, the only line contains a string s, which is the original sentence.

The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.

 

Output

For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.

 

Sample Input

2
ohayougozaimasu
daijyoubudesu

 

Sample Output

Case #1: ohayougozaimasunanodesu
Case #2: daijyoubunanodesu

 

Source

2013 ACM/ICPC Asia Regional Chengdu Online

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
using namespace std;

int main()
{
int T;
cin>>T;
int tot = 0;
while(T--)
{
string a;
cin>>a;
cout<<"Case #"<<++tot<<": ";
int len = a.length();
if(a[len-1] == 'u' && a[len-2] == 's' && a[len-3] == 'e' && a[len-4] == 'd' &&
a[len-5] == 'o' && a[len-6] == 'n' && a[len-7] == 'a' && a[len-8] == 'n')
{
cout<<a<<endl;
}
else if(a[len-1] == 'u' && a[len-2] == 's' && a[len-3] == 'e' && a[len-4] == 'd')
{
for(int i=0;i<len -4;i++)
{
cout<<a[i];
}
cout<<"nanodesu"<<endl;
}
else
{
cout<<a<<"nanodesu"<<endl;
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: