您的位置:首页 > 其它

并查集变式 POJ 1703 Find them,Catch them

2017-03-10 20:36 316 查看
Find them,Catch them

Time limit         1000 msMemory limit    10000 kB

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to.
The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message
as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.


        解决这个题的关键是设置了一个数组r[ ],用来表示并查集中一个节点与其父节点的关系(同帮派或不同帮派),然后就是运用并查集找到两个有联系的节点,判断两者的关系。具体到判断的过程,其思想有点像二进制逻辑代数中的同或运算(朋友的朋友是朋友,敌人的朋友是敌人,朋友的敌人是敌人,敌人的敌人是朋友)。
代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int f[100005];
bool r[100005];//relationship
int i;

void Init(int n)
{
for (i=1; i<=n; i++)
{
f[i] = i;
r[i] = 1;
}
}

int Find(int a)
{
if (a == f[a])
return a;
else
{
int tem = f[a];
f[a] = Find(f[a]);
r[a] = (r[tem]+r[a]+1)%2;//该节点与父节点的关系 和 父节点与父父节点的关系 的关系,
//即朋友的朋友是朋友,敌人的朋友是敌人,朋友的敌人是敌人,敌人的敌人是朋友
//随着路径的更新,a与父节点的关系也是改变的
//递归的最终结果是,确定a与根节点的关系
}
return f[a];
}

void Mix(int a, int b)
{
int fa, fb;
fa = Find(a);
fb = Find(b);
if (fa != fb)
{
f[fa] = fb;//将b的根节点赋给a的根节点的父节点,即把b作为a的根节点
r[fa] = (r[a]+r[b])%2;//只更新fa节点的r[],fa结点以下的结点的r[]不需要改
}
}

int main()
{
int T, N, M;
char ch;
int a, b;
scanf ("%d",&T);
while (T--)
{
scanf ("%d %d",&N,&M);
Init(N);
for (i=1; i<=M; i++)
{
getchar();
scanf ("%c %d %d",&ch,&a,&b);
if (ch == 'A')
{
if (Find(a) == Find(b))
{
if ((r[a]+r[b])%2 == 0)
printf ("In the same gang.\n");
else
printf("In different gangs.\n");
}
else
printf ("Not sure yet.\n");
}
else if (ch == 'D')
Mix(a, b);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: