您的位置:首页 > 其它

zoj 2388 Beat the Spread!

2017-03-10 20:33 471 查看
Beat the Spread!Time Limit: 2 Seconds Memory Limit: 65536 KB
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?

Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.

Sample Input

2
40 20
20 40

Sample Output

30 10
impossible

#include <iostream>
using namespace std;
int main(){
int n, s, d;
//x + y = s;
//x - y = d;
int x, y;//因为是绝对差,所以直接假定x大,y小
cin >> n;
while(n--){
cin >> s >> d;
//x,y必须为整数,由方程得2x = s + d;故s + d为偶数
if((s + d) % 2 != 0){
cout << "impossible" << endl;
continue;
}
else
x = (s + d) / 2;
y = s - x;
if(y < 0)
cout << "impossible" << endl;
else
cout << x << " " << y << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: