您的位置:首页 > 其它

[HDU 2222]Keywords Search(AC自动机)

2017-03-10 19:27 405 查看

Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.

Wiskey also wants to bring this feature to his image retrieval system.

Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.

##Output

Print how many keywords are contained in the description.

Sample Input

1

5

she

he

say

shr

her

yasherhs

Sample Output

3

Solution

写个模板花了好长时间,感觉细节什么的还是很麻烦,要记要记

(暗中观察了很多模板…)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<queue>
using namespace std;
int T,n,siz,root;
int q[600000],head,tail;
char text[1000005],keyword[55];
struct Node{
int next[26],fail,cnt;
bool vis;
}Trie[600000];
int newnode()
{
Trie[++siz].fail=0;
Trie[siz].cnt=0;
Trie[siz].vis=0;
for(int i=0;i<26;i++)
Trie[siz].next[i]=0;
return siz;
}
void _insert(char *word)
{
int i=0,p=root;
while(word[i])
{
int idx=word[i]-'a';
if(!Trie[p].next[idx])
Trie[p].next[idx]=newnode();
p=Trie[p].next[idx];
i++;
}
Trie[p].cnt++;
}
void _build()
{
queue<int>q;
q.push(root);
while(!q.empty())
{
int p=q.front();
for(int i=0;i<26;i++)
{
int t=Trie[p].fail;
while(t&&!Trie[t].next[i])t=Trie[t].fail;
if(Trie[p].next[i])
{
Trie[Trie[p].next[i]].fail=t?Trie[t].next[i]:root;
q.push(Trie[p].next[i]);
}
else Trie[p].next[i]=t?Trie[t].next[i]:root;
}
q.pop();
}
}
int _query()
{
int i=0,p=root,ans=0;
while(text[i])
{
int idx=text[i]-'a';
p=Trie[p].next[idx];
int t=p;
while(t&&!Trie[t].vis)
{
Trie[t].vis=1;
ans+=Trie[t].cnt;
t=Trie[t].fail;
}
i++;
}
return ans;
}
int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
siz=0;root=newnode();
for(int i=1;i<=n;i++)
{
scanf("%s",keyword);
_insert(keyword);
}
scanf("%s",text);
_build();
printf("%d\n",_query());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: