您的位置:首页 > 其它

zoj 2476 Total Amount

2017-03-10 18:08 323 查看
Total AmountTime Limit: 2 Seconds Memory Limit: 65536 KB
Given a list of monetary amounts in a standard format, please calculate the total amount.

We define the format as follows:

1. The amount starts with '$'.

2. The amount could have a leading '0' if and only if it is less then 1.

3. The amount ends with a decimal point and exactly 2 following digits.

4. The digits to the left of the decimal point are separated into groups of three by commas (a group of one or two digits may appear on the left).

Input

The input consists of multiple tests. The first line of each test contains an integer N (1 <= N <= 10000) which indicates the number of amounts. The next N lines contain N amounts. All amounts and the total amount are between $0.00 and $20,000,000.00, inclusive. N=0 denotes the end of input.

Output

For each input test, output the total amount.

Sample Input

2
$1,234,567.89
$9,876,543.21
3
$0.01
$0.10
$1.00
0

Sample Output

$11,111,111.10
$1.11

一开始没有将字符串中的其他符号去掉,将直接加了,漏掉了很多情况,所以还是应该老老实实的去掉其他符号后做大数加法。

输出的时候再把符号加回去。

#include <iostream>
#include <string>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;

string add(string s1, string s2){
int flag = 0, sum, i;
string s = "";
int len1 = s1.length(), len2 = s2.length();
if(len1 < len2){
swap(s1, s2);
}
len1 = s1.length(), len2 = s2.length();
reverse(s1.begin(), s1.end());
reverse(s2.begin(), s2.end());
for(i = 0; i < len1 && i < len2; i++){
sum = (int)(s1[i] - '0') + (int)(s2[i] - '0') + flag;
s += (char)(sum % 10 + '0');
flag = sum / 10;
}
while(i < len1){
sum = (int)(s1[i] - '0') + flag;
s += (char)(sum % 10 + '0');
flag = sum / 10;
i++;
}
if(flag == 1)
s += '1';
reverse(s.begin(), s.end());
return s;
}

int main(){
string s1, s2, str1, str2;
char c;
int n, i;
while(cin >> n){
if(n == 0)
break;
s1 = "";
while(n--){
cin >> s2;
str2 = "";
//去符号
int len1 = s1.length(), len2 = s2.length();
for(i = 0; i < len2; i++)
if(s2[i] >= '0' && s2[i] <= '9')
str2 += s2[i];
s1 = add(s1, str2);
}
reverse(s1.begin(), s1.end());
int len = s1.length();
string ans = "";
for(int i = 0; i < len; i++){
ans = ans + s1[i];
if(i == 1)
ans = ans + '.';
if(i > 2 && (i - 1) % 3 == 0 && i != len - 1)
ans = ans + ',';
}
ans += '$';
reverse(ans.begin(), ans.end());

cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: