您的位置:首页 > 其它

hduoj 2824 The Euler function【欧拉函数 打表】

2017-03-09 21:03 423 查看

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6449    Accepted Submission(s): 2720


[align=left]Problem Description[/align]
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics.
Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

[align=left]Input[/align]
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

[align=left]Output[/align]
Output the result of (a)+ (a+1)+....+ (b)
 

[align=left]Sample Input[/align]

3 100

 

[align=left]Sample Output[/align]

3042
#include<cstdio>
#include<cstring>
const int maxn = 3000010;
long long phi[maxn];
void Euler(){
for(int i = 2; i < maxn ; i++){
if(!phi[i]){
for(int j = i; j < maxn; j += i){
if(!phi[j])
phi[j] = j;
phi[j] = phi[j] / i * (i-1);
}
}
}
for(int i = 3; i < maxn; i++)
phi[i] += phi[i-1];
}
int main(){
int a,b;
Euler();
while(~scanf("%d%d",&a,&b)){
printf("%lld\n",phi[b] - phi[a-1]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: