您的位置:首页 > 其它

题目1001:A+B for Matrices

2017-03-09 16:28 393 查看
题目描述:

This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

The input is terminated by a zero M and that case must NOT be processed.

输出:

For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:

2 2

1 1

1 1

-1 -1

10 9

2 3

1 2 3

4 5 6

-1 -2 -3

-4 -5 -6

0

样例输出:

1

5

分析:大致意思就是求A加B矩阵的全0行和全0列的总数(the total number of zero rows and columns of A+B),个人觉得这个翻译还是够呛的。

#include<iostream>
using namespace std;
int main()
{
int m,n;
int array[20][20];
int b[10];
int sum=0;
cin>>m;
while(m!=0)
{
int count=0;
cin>>n;
for(int i=0;i<2*m;i++)
for(int j=0;j<n;j++)
cin>>array[i][j];
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
array[i][j]=array[i][j]+array[i+m][j];
for(int i=0;i<m;i++)
{
int j;
for(j=0;j<n;j++)
{
if(array[i][j]!=0)
break;
}
if(j==n)
count++;
}

for(int i=0;i<n;i++)
{
int j;
for(j=0;j<m;j++)
{
if(array[j][i]!=0)
break;
}
if(j==m)
count++;
}
b[sum]=count;
++sum;
cin>>m;
}
for(int i=0;i<sum;i++)
cout<<b[i]<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: